Back to overview
Degraded
We're investigating the cause of degraded performance.
Apr 18, 2026 at 2:43pm UTC
Affected services
Dashboard
Dashboard Stats
Authentication
CSRF
Resolved
Apr 18, 2026 at 2:52pm UTC
Fixed
Affected services
Updated
Apr 18, 2026 at 2:50pm UTC
We have identified the root cause of the issue. It will be resolved within 10-15 minutes. Thanks for your patience!
Affected services
Created
Apr 18, 2026 at 2:43pm UTC
Degraded Authentication & Dashboard performance, investigating issue.
Affected services